Skip to main content
Topic: 2005 Endura 6340, 8.1 gas, Suburban furnace, Dometic Duo-therm AC (Read 17 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

2005 Endura 6340, 8.1 gas, Suburban furnace, Dometic Duo-therm AC

Yahoo Message Number: 17069
Hey folks,

Interesting problem here. I walked by the motorhome the other day and heard the furnace running. Went inside and the front AC was also running, fan and compressor. Checked the t'stat heat/off/cool switch and it's in the off position. Fan switch is in the auto position. Fan speed switch is in the high position. I didn't have time to troubleshoot but assumed because the t'stat is the only thing common to both the furnace and front AC it was the problem. Received the new one today, installed it and still have the same problem.

Last week we were at a campsite in Algoma WI. During the night a storm came through and the shroud blew off the front AC. Some water did leak into the coach. I checked the electrical connections and they all seemed dry. The furnace, AC, and t`stat all worked as they should afterwards. Two days later we stopped at Gander in Wausau bought a new shroud and put it on. Everything worked ok the rest of the trip.

I'll continue troubleshooting, but I'm curious if anyone has any experience with this issue.

Re: 2005 Endura 6340, 8.1 gas, Suburban furnace, Dometic Duo-therm

Reply #1
Yahoo Message Number: 17070
There are a group of dip switches inside box in AC unit maybe they are not in proper position. I did a repair on one by toggling all the switches. I found a manual on Internet that showed what each switch was for.
Best
Ron Hall

Best
Ron Hall